Voicemail delivery to email is broken
Incident Report for Systems Status
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 09:23 PST
Investigating
The delivery of voicemail messages to email inboxes is currently broken. IT is working on this issue. Voicemail messages can still be retrieved via telephone.
Posted Jan 10, 2024 - 10:39 PST
This incident affected: Phone System.