Phone service is degraded
Incident Report for Chemeketa Systems
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 11:35 PST
Update
Outgoing call issues have been mostly restored. All calls will go through; however, some caller identification services are seeing partial information.
Posted Nov 04, 2024 - 16:46 PST
Update
Our phone system is currently experiencing issues with some outgoing calls to 911. There is an open service request with our phone provider.

Microsoft Teams calling or your cell phone will still connect to 911 for emergency calls.
Posted Oct 31, 2024 - 16:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2024 - 18:56 PDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2024 - 18:56 PDT
Investigating
Our phone system is currently experiencing issues with some outgoing phone calls. This includes 911. There is an open service request with our phone provider.
Posted Oct 30, 2024 - 18:56 PDT
This incident affected: Phone System.