CCBI Power Outage

Incident Report for Chemeketa Systems

Resolved

Power has been restored at CCBI.
Posted Jul 22, 2026 - 23:29 PDT

Identified

Some areas at CCBI lost wired network connectivity due to a power outage in downtown Salem. Essential systems and Wi-Fi are running on emergency backup power.
Posted Jul 22, 2026 - 22:40 PDT
This incident affected: Internet connectivity.