Banner Admin Pages access with Chrome, Edge

Incident Report for Chemeketa Systems

Identified

Edge now seems to have the same issue which affected Chrome.

The temporary fix to Chrome should continue to work, so you should be able to use Chrome or Firefox for Admin Pages if Edge stops working for you. We will investigate a temporary fix for Edge while we wait for Ellucian to release a more permanent fix for Admin Pages.
Posted Dec 08, 2025 - 08:15 PST

Monitoring

A temporary fix is in place which should allow Chrome to work with Banner Admin Pages. A permanent solution will require an upgrade to Admin Pages, which the vendor is working on.

If you still have issues with Chrome not loading a page in Admin Pages, try restarting your computer. If that does not resolve the problem, switch to Edge or Firefox, and open a Help Center work item.
Posted Nov 08, 2025 - 11:57 PST

Investigating

The newest version of Chrome may have issues accessing Banner Admin Pages. The major symptom is after loading Admin Pages and entering the name of a page/form, the frame where the page/form would load never advances beyond the spinning loading graphic.

If you encounter problems with Chrome loading Admin Pages, use Edge or Firefox.
Posted Oct 29, 2025 - 10:35 PDT
This incident affects: Banner (Admin Pages) and Banner Non-Production (TBAN Admin Pages).